TABLE OF CONTENTS

Symptom

While trying to update the firmware on a NI hardware device, you might experience one of the following scenarios: 

  • Your device is not at all recognized by the Firmware Updater.
  • Our Firmware Updater recognizes the device and detects outdated firmware, but the updater aborts with the device no longer being recognized.
  • The firmware update aborts with an error message which states:
    "An error occurred while updating your *NI Device* (error -2)"

Causes

The behaviour can be caused by one or more of the following:

  • The latest driver for your device is not installed. 
  • A web browser or cloud service is running while attempting to update the firmware. 
  • Your operating system requires an update (Windows 10 only).

Solutions

  1. Ensure that the latest driver for your device is installed. Please find all drivers available on our download page. 
  2. Before launching the Firmware Updater, ensure that all web browser windows are closed and that there are no cloud services running in the background.

  3. If you are using Windows 10, please make sure the latest update is installed. You can find this option in: Settings > Updates & security > Windows Update > Check for Updates

  4. If the previous solutions did not work, please try running the Firmware Updater on a guest account of your operating system, or if available on a different computer.